Benachrichtigungen
Alles löschen

MQTT Datenpunkt Einrichtung und Test

New Member Gast

Hallo zusammen,

ich möchte aus meiner Wallbox einen Modus(Integer) auslesen 0,1,2,3,4. Über die MQTT Explorer Software klappt das prima, auch kann ich den Modus setzen. Scheinbar akzeptiert die Wallbox keine Json Syntax bei dem Modus sondern wenn ich den Pfad "openWB/global/ChargeMode" nutze und eine 2 publishe, dann funktioniert das.

 

Nun zum Problem:

Ich weiß nicht, was ich bei den Datenpunkt eingeben muss und habe auch keine Idee, wie ich die MQTT Verbindung und den Datenpunkt testen kann

Wer kann mir helfen?

 

Absoluter Gesamtpfad: 192.168.2.216/openWB/global/ChargeMode

Version XHome 1.0.67

 

Danke & Gruß,

Thorsten

Dieses Thema wurde geändert Vor 2 Jahren von Anonym
Zitat
Themenstarter Veröffentlicht : 28/10/2021 5:57 pm
 Jens
Active Member

Hallo zusammen,

auch mich interessiert wie die Datenpunkte in Xsolution per MQTT für die OpenWB eingetragen werden.

Der entsprechende Link "Daternpunkte MQTT" zu OpenWB

https://openwb.de/forum/viewtopic.php?f=6&t=577

 

Gruß Jens

AntwortZitat
Veröffentlicht : 01/11/2021 7:11 pm
New Member

Hallo vielleicht kann mir von euch wer helfen.

Ich bekomme keine Verbindung zum Mosquitto Broker der Schnittstellenstatus zeigt immer Fehler.

Ich habe die IP + Port, Benutzer und Passwort eingegeben und es geht nicht.

Mit dem Mqtt fx funktionierts.

Danke im voraus

Diese r Beitrag wurde geändert Vor 2 Jahren von LukasM
AntwortZitat
Veröffentlicht : 22/03/2022 8:05 pm
 maha
New Member

@tschmidt, @LukasM habt ihr ein "tcp://" vor eure IP-Adresse geschrieben?

Also tcp://xxx.xxx.xxx.xxx:port.

Das war der Fehler bei mir.

Habe ich aus der Online-Hilfe ( Link entfernt ).

Wenn man sich strikt daran hält, läuft alles perfekt.

Gruß

maha

AntwortZitat
Veröffentlicht : 04/04/2022 5:31 pm
Active Member

Hallo zusammen

Ich bringe einefach keine Verbundung zum mqtt-Broker hin. Ich habe Mosquitto laufen (auf dem gleichen PC wie Xhome). Mit MQTT.fx kriege ich problemlos eine Verbindung. Auch mit anderen Geräten (z.B. M5Stack Core2) und die kommunizieren auch alle perfekt untereinander. Port ist der 1883. Wie vermutlich immer bei Mosquitto.

Passwort verwende ich keines. Ich habe in der mosquitto.conf den Eintrag "allow_anonymous true" gesetzt. Hat jemand eine Ahnung, was ich noch versuchen könnte?

 

AntwortZitat
Veröffentlicht : 27/12/2022 2:10 pm
Cookie Consent mit Real Cookie Banner