Info: Bilder können nur mit der Antwort Funktion eingebettet werden, mit der Schnellantwort funktioniert dies nicht!

Willkommen Gast 

Infos ein-/ausblenden

Willkommen Gast! Um Beiträge zu verfassen musst Du registriert sein.





Seiten: [1]
Autor Thema:Linux oder Windows?
Pmeger
Profi
Beiträge: 136
Permalink
Beitrag Linux oder Windows?
am 15.4.2018, 13:28
Zitat

Da der EVO irgendwie nicht mehr so performant auf dem RasPi läuft habe ich mir nun einen NUC i5 zugelegt. Nun die Frage: lieber ein Linux (wenn ja, welches) oder Windows?
Primär möchte ich xhome EVO dort laufen lassen.

Schwenn
Profi
Beiträge: 199
Permalink
Beitrag Re: Linux oder Windows?
am 24.4.2018, 19:40
Zitat

Hallo Pmeger,

ich plane gerade den EVO auf einem Pi3, aber damit scheint es ja anscheinend nicht so gut zu laufen.
Für welches System hast du dich entschieden?

Gruß
Schwenn

Wago 750-849 mit KNX / EVO (Pi3) / DALI / EnOcean / M-Bus / ModBus / Netatmo / HUE / Sonos / Echodot (Alexa) / HomeKit / X-Home 7 (Pi2) /

Pmeger
Profi
Beiträge: 136
Permalink
Beitrag Re: Linux oder Windows?
am 24.4.2018, 21:59
Zitat

Laufen tut es auch auf einem Pi3, aber ist schon recht lahm. Mir geht es neben Smarthome auch um Datenlogging. Habe eine recht große Solar Anlage (Ost und West) mit 3 Speichern und viel Photovoltaik + Speicher auf dem Dach. Möchte da eben allerhand Daten mitschreiben: Temperatur von jedem Kollektor, Vorlauf, Rücklauf, Speicher unten/mitte/oben usw...
Aber irgendwie ist der xhome evo in meinem Fall eine echte Krücke 🙁
Andauernd Ladezeiten bei den Graphen oder die Graphen kommen gar nicht erst...

Habe jetzt einen Intel NUC der 7. Generation mit i5 und 512GB m2 + 512GB SSD als Backup. OS habe ich xubuntu 16.04 laufen.
Bin mal gespannt wie das sich nach ein paar Wochen verhält.

Grüße

hurzdemurz
Profi
Beiträge: 145
Permalink
Beitrag Re: Linux oder Windows?
am 18.5.2019, 19:59
Zitat

Und, wie sind die Erfahrungen. Spiele mit dem Gedanken, von Win10 auf Linux (CentOS) zu wechseln.

Ray1
Profi
Beiträge: 696
Permalink
Beitrag Re: Linux oder Windows?
am 19.5.2019, 20:19
Zitat

Hallo hurzdemurz

habe mit Debian und CentOS bisher sehr gute Erfahrungen gemach, läuft definitiv auf beiden Systemen sehr gut.

Gruß Ray

hurzdemurz
Profi
Beiträge: 145
Permalink
Beitrag Re: Linux oder Windows?
am 29.5.2019, 11:30
Zitat

Hallo Ray,

darf ich eine Frage anschließen - habe ein kleines Problem, XHome unter CentOS ans laufen zu kriegen - oder besser wieder zu stoppen.

'service xhome start' funktioniert wunderbar.
'service xhome stop' allerdings nicht. Dort bekomme ich immer gesagt, dass der Service nicht laufen würde. Stimmt aber nicht. Grund ist vermutlich, dass der Service nicht unter dem Namen xhome läuft, sondern unter dem Namen java. Was mache ich denn hier falsch?

Gute Tips sind willkommen 😉

Gruß

Stefan

Ray1
Profi
Beiträge: 696
Permalink
Beitrag Re: Linux oder Windows?
am 1.6.2019, 16:57
Zitat

Hallo Stefan,

ich nutze zum "start-stop-status-restart" auf der Konsole

systemctl start xhome

und das als root

Gruß Ray

hurzdemurz
Profi
Beiträge: 145
Permalink
Beitrag Re: Linux oder Windows?
am 3.6.2019, 23:23
Zitat

Hallo Ray,
danke für den Tip - führt aber zumindest bei mir zum gleichen Problem.

systemctl start xhome funktioniert tadellos, der Xhome Evo wird gestartet.

systemctl stop xhome bringt zwar ebenfalls keinen Fehler, der Server läuft aber unverändert weiter.

Weitere Hinweise wären willkommen, denn jeweils den passenden Java-Prozess rauszufinden und diesen manuell zu killen, ist keine schöne Lösung 😉

Gruß

Stefan

Ray1
Profi
Beiträge: 696
Permalink
Beitrag Re: Linux oder Windows?
am 4.6.2019, 06:04
Zitat

Hallo Stefan,

was kommt bei dir mit "Status" ?
ich schaue heute Abend noch mal nach, wie ich es bei mir konfiguriert habe.

Gruß Ray

hurzdemurz
Profi
Beiträge: 145
Permalink
Beitrag Re: Linux oder Windows?
am 5.6.2019, 19:13
Zitat

systemctl status xhome liefert...
...wenn Xhome gestoppt ist:
● xhome.service - (null)
Loaded: loaded (/etc/rc.d/init.d/xhome; bad; vendor preset: disabled)
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)

Jun 03 23:16:14 xxx.fritz.box systemd[1]: Starting (null)...
Jun 03 23:16:14 xxx.fritz.box xhome[31804]: /usr/share/Xhome_Evolution/root_application-1.0.49.jar
Jun 03 23:16:14 xxx.fritz.box sudo[31812]: <b> root : TTY=unknown ; PWD=/usr/share/Xhome_Evolution ; USER=root ; COMMAND=/bin/bash -c java -Xmx1024M -Xms512M -jar /usr/share/Xhome_Evolution/root_application-1.0.49.jar > /dev/null 2> /dev/null & echo $! >/var/run/xhome_server.pid</b>
Jun 03 23:16:14 xxx.fritz.box xhome[31804]: Starting Xhome_Server started PID=31816
Jun 03 23:16:14 xxx.fritz.box systemd[1]: Started (null).
Jun 03 23:18:43 xxx.fritz.box systemd[1]: Stopping (null)...
Jun 03 23:18:43 xxx.fritz.box xhome[32908]: /usr/share/Xhome_Evolution/root_application-1.0.49.jar
Jun 03 23:18:44 xxx.fritz.box xhome[32908]: Xhome_Server is not running
Jun 03 23:18:44 xxx.fritz.box systemd[1]: Stopped (null).

...wenn Xhome gestartet ist:
● xhome.service - (null)
Loaded: loaded (/etc/rc.d/init.d/xhome; bad; vendor preset: disabled)
Active: active (exited) since Mi 2019-06-05 18:59:04 CEST; 1min 17s ago
Docs: man:systemd-sysv-generator(8)
Process: 36106 ExecStart=/etc/rc.d/init.d/xhome start (code=exited, status=0/SUCCESS)

Jun 05 18:59:04 xxx.fritz.box systemd[1]: Starting (null)...
Jun 05 18:59:04 xxx.fritz.box xhome[36106]: /usr/share/Xhome_Evolution/root_application-1.0.49.jar
Jun 05 18:59:04 xxx.fritz.box sudo[36114]: root : TTY=unknown ; PWD=/usr/share/Xhome_Evolution ; USER=root ; COMMAND=/bin/bash -c java -Xmx1024M -Xms512M -jar /usr/share/Xhome_Evolution/root_application-1.0.49.jar > /dev/null 2> /dev/null & echo $! >/var/run/xhome_server.pid
Jun 05 18:59:04 xxx.fritz.box xhome[36106]: Starting Xhome_Server started PID=36117
Jun 05 18:59:04 xxx.fritz.box systemd[1]: Started (null).

...wenn Xhome über systemctl stop xhome nur scheinbar gestoppt wurde:
● xhome.service - (null)
Loaded: loaded (/etc/rc.d/init.d/xhome; bad; vendor preset: disabled)
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)

Jun 03 23:18:44 xxx.fritz.box systemd[1]: Stopped (null).
Jun 05 18:59:04 xxx.fritz.box systemd[1]: Starting (null)...
Jun 05 18:59:04 xxx.fritz.box xhome[36106]: /usr/share/Xhome_Evolution/root_application-1.0.49.jar
Jun 05 18:59:04 xxx.fritz.box sudo[36114]: root : TTY=unknown ; PWD=/usr/share/Xhome_Evolution ; USER=root ; COMMAND=/bin/bash -c java -Xmx1024M -Xms512M -jar /usr/share/Xhome_Evolution/root_application-1.0.49.jar > /dev/null 2> /dev/null & echo $! >/var/run/xhome_server.pid
Jun 05 18:59:04 xxx.fritz.box xhome[36106]: Starting Xhome_Server started PID=36117
Jun 05 18:59:04 xxx.fritz.box systemd[1]: Started (null).
Jun 05 19:04:00 xxx.fritz.box systemd[1]: Stopping (null)...
Jun 05 19:04:00 xxx.fritz.box xhome[37427]: /usr/share/Xhome_Evolution/root_application-1.0.49.jar
Jun 05 19:04:00 xxx.fritz.box xhome[37427]: Xhome_Server is not running
Jun 05 19:04:00 xxx.fritz.box systemd[1]: Stopped (null).

Sieht aus wie gestoppt, läuft aber - zumindest kann ich die html-Seite unter xxx.fritz.box bzw. der IP-Adresse aufrufen und bedienen.

Bin nicht genug Linux-Experte, um das Problem zu identifizieren und zu beseitigen. Jede Hilfe wäre also willkommen.

Ach ja, ein 'service xhome stop' liefert trotz Erreichbarkeit des Frontend Xhome_Server is not running.
Läuft nach wie vor mit dem Prozessnamen java und der PID 36117.

Gruß

Stefan

P.S.: klar, kill 36117 löst das Problem, dann wird der Xhome Server tatsächlich beendet. Ist aber keine Lösung, sondern nur ein workaround.

Ray1
Profi
Beiträge: 696
Permalink
Beitrag Re: Linux oder Windows?
am 10.6.2019, 00:17
Zitat

Hallo Stefan,

Meine Ausgaben von systemctl Start|Stop|Status sind identisch mit deinen, allerdings ist bei mir nach Stop auch der Java-Prozess aus und der Server nicht mehr erreichbar. Hmm.....
Wird xhome evtl 2 mal gestartet??? Wobei dann wäre es nicht die selbe PID ....
für einen autostart vom System, ist die PID vom xhome ziehmlich hoch.
Vielleicht mal den Service disablen und dann nach Neustart per Hand die xhome mit Start|Stop|Status testen, ob daas funzt.

Im Moment fällt mir da leider auch nichts mehr ein

Gruß Ray

hurzdemurz
Profi
Beiträge: 145
Permalink
Beitrag Re: Linux oder Windows?
am 11.6.2019, 13:44
Zitat

Hallo Ray,
danke trotzdem für die Mithilfe.
Eine letzte Idee bzw. Rückfrage noch: ich habe die Installation unter CentOS nach der Anleitung in der Xhome Doku versucht.
Allerdings gibt es dort den Abschnitt

Service aktivieren:
sudo update-rc.d xhome defaults
sudo update-rc.d xhome enable

Die Befehle funktionieren allerdings bei mir unter CentOS 7 nicht. Kann das vielleicht der Grund sein? Und falls ja, was wären denn die analogen Befehle unter CentOS?
Mit googeln war ich einigermaßen erfolglos 🙁
Sorry, bin eben erst noch auf dem Weg zum Linux-Kenner.

Gruß
Stefan

hurzdemurz
Profi
Beiträge: 145
Permalink
Beitrag Re: Linux oder Windows?
am 11.6.2019, 13:47
Zitat

Vermutlich brauche ich chkconfig xhome on oder ähnliches.
Aber on entspricht dann wohl dem 'enable', nur wie setze ich dann die 'defaults'?

Ray1
Profi
Beiträge: 696
Permalink
Beitrag Re: Linux oder Windows?
am 11.6.2019, 22:16
Zitat

Hallo Stefan,

hier ist es sehr gut beschrieben, wie du den Service einrichtest
https://www.opentechguides.com/how-to/article/centos/169/systemd-custom-service.html

Gruß Ray

hurzdemurz
Profi
Beiträge: 145
Permalink
Beitrag Re: Linux oder Windows?
am 12.6.2019, 15:46
Zitat

Hallo Ray, super, vielen Dank. Werde mir das mal zu Gemüte führen und versuchen, ein passendes unit file zu erstellen.

Seiten: [1]

Durch die weitere Nutzung der Seite stimmst du der Verwendung von Cookies zu. Weitere Informationen

Die Cookie-Einstellungen auf dieser Website sind auf "Cookies zulassen" eingestellt, um das beste Surferlebnis zu ermöglichen. Wenn du diese Website ohne Änderung der Cookie-Einstellungen verwendest oder auf "Akzeptieren" klickst, erklärst du sich damit einverstanden.

Schließen