Benachrichtigungen
Alles löschen

EVO SENDET KEINE EMAILS - Brauche dringend Abhilfe


(@snydman)
Active Member
Beigetreten: Vor 10 Jahren
Beiträge: 10
Themenstarter  

Tach Gemeinde Tach Xsolution,

seit Tagen sendet mein Evo keine Emails mehr. Keine Evo-Einstellungen verändert. Der E-Mail-Account funktioniert über E-Mail-Programm tadellos. Das einzigste was ich gemacht habe, ist ein Java-Update von 8.0.301 auf 8.0.311. Befehle in der Logik werden ausgewertet, Server auf 1.0.67 geupdatet. (Vorher war die 1.0.60 drauf....auch kein E-Mail Versand). Server mehrere Mail gestartet....Browser-Cache mehrere Mal geleert.

Was kann das sein?

Kurzer Auszug aus dem Log dazu:

2021-11-02 1700,826 - [INFO] [de.xsolution.gateways.gateway_email_smtp.Gateway_Handler_Service_impl.send_email(Gateway_Handler_Service_impl.java send_email smtp
2021-11-02 1701,081 - [ERROR] [de.xsolution.gateways.gateway_email_smtp.EMail_SMTP.sendMail(EMail_SMTP.java Could not send e-mail to 'snydman@arcor.de'.
org.apache.commons.mail.EmailException: Sending the email to the following server failed : mail.arcor.de:465
at org.apache.commons.mail.Email.sendMimeMessage(Email.java:1469)
at org.apache.commons.mail.Email.send(Email.java:1496)
at de.xsolution.gateways.gateway_email_smtp.EMail_SMTP.sendMail(EMail_SMTP.java:191)
at de.xsolution.gateways.gateway_email_smtp.EMail_SMTP.sendMail(EMail_SMTP.java:95)
at de.xsolution.gateways.gateway_email_smtp.EMail_SMTP.sendMail(EMail_SMTP.java:73)
at de.xsolution.gateways.gateway_email_smtp.Gateway_Email_smtp.send_email(Gateway_Email_smtp.java:261)
at de.xsolution.gateways.gateway_email_smtp.Gateway_Handler_Service_impl.send_email(Gateway_Handler_Service_impl.java:443)
at de.xsolution.logik.items.email_smtp.execute(email_smtp.java:172)
at de.xsolution.logik.Logik_Executor$1.run(Logik_Executor.java:156)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: javax.mail.MessagingException: Could not connect to SMTP host: mail.arcor.de, port: 465;
nested exception is:
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:2120)
at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:712)
at javax.mail.Service.connect(Service.java:388)
at javax.mail.Service.connect(Service.java:246)
at javax.mail.Service.connect(Service.java:195)
at javax.mail.Transport.send0(Transport.java:254)
at javax.mail.Transport.send(Transport.java:124)
at org.apache.commons.mail.Email.sendMimeMessage(Email.java:1459)
... 15 more
Caused by: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
at sun.security.ssl.Alert.createSSLException(Unknown Source)
at sun.security.ssl.TransportContext.fatal(Unknown Source)
at sun.security.ssl.TransportContext.fatal(Unknown Source)
at sun.security.ssl.TransportContext.fatal(Unknown Source)
at sun.security.ssl.CertificateMessage$T12CertificateConsumer.checkServerCerts(Unknown Source)
at sun.security.ssl.CertificateMessage$T12CertificateConsumer.onCertificate(Unknown Source)
at sun.security.ssl.CertificateMessage$T12CertificateConsumer.consume(Unknown Source)
at sun.security.ssl.SSLHandshake.consume(Unknown Source)
at sun.security.ssl.HandshakeContext.dispatch(Unknown Source)
at sun.security.ssl.HandshakeContext.dispatch(Unknown Source)
at sun.security.ssl.TransportContext.dispatch(Unknown Source)
at sun.security.ssl.SSLTransport.decode(Unknown Source)
at sun.security.ssl.SSLSocketImpl.decode(Unknown Source)
at sun.security.ssl.SSLSocketImpl.readHandshakeRecord(Unknown Source)
at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
at com.sun.mail.util.SocketFetcher.configureSSLSocket(SocketFetcher.java:598)
at com.sun.mail.util.SocketFetcher.createSocket(SocketFetcher.java:372)
at com.sun.mail.util.SocketFetcher.getSocket(SocketFetcher.java:217)
at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:2084)
... 22 more
Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
at sun.security.validator.PKIXValidator.doBuild(Unknown Source)
at sun.security.validator.PKIXValidator.engineValidate(Unknown Source)
at sun.security.validator.Validator.validate(Unknown Source)
at sun.security.ssl.X509TrustManagerImpl.validate(Unknown Source)
at sun.security.ssl.X509TrustManagerImpl.checkTrusted(Unknown Source)
at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(Unknown Source)
... 38 more
Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
at sun.security.provider.certpath.SunCertPathBuilder.build(Unknown Source)
at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(Unknown Source)
at java.security.cert.CertPathBuilder.build(Unknown Source)
... 44 more

 

Strom macht klein....schwarz....und hässlich!


Zitat
(@snydman)
Active Member
Beigetreten: Vor 10 Jahren
Beiträge: 10
Themenstarter  

Fehler gefunden...liegt am Provider mit dem großen V......mit einer anderen E-Mail-Adresse geht es!

Strom macht klein....schwarz....und hässlich!


AntwortZitat
(@snydman)
Active Member
Beigetreten: Vor 10 Jahren
Beiträge: 10
Themenstarter  

So....siehe da, das Thema ist NICHT geklärt.

Habe gerade einen neuen Server aufgesetzt. Komplett neue Hardware, neue Evo-Lizenz. Version 1.0.60 mit java 1.8.311.

Das gleiche Phänomen wie oben beschrieben. Auch im Log...steht das gleiche drin. Die Emails wurden versucht, aus der Logik heraus zu senden. Der Logik-Baustein sagt: Email send ok. Auch die angelegte Smtp-Schnittstelle sagt: OK. Das log-File sagt...Could not send e-mail....

Ausprobiert mit zwei unterschiedlichen Mail-Providern und unterschiedlichen Verschlüsselungen....immer der gleiche Fehler.

Ich brauche Hilfe dazu!

Strom macht klein....schwarz....und hässlich!


AntwortZitat
(@snydman)
Active Member
Beigetreten: Vor 10 Jahren
Beiträge: 10
Themenstarter  

NACHTAG:

auch mit der Version 11.0.xx und jdk11 ist senden per E-Mail nicht möglich. Schnittstellen sagen: alles ok....Log sagt: kann nicht senden. auch mit ausgeschalteter Firewall das gleiche.

Was hab ich vergessen einzustellen???

Strom macht klein....schwarz....und hässlich!


AntwortZitat
(@snydman)
Active Member
Beigetreten: Vor 10 Jahren
Beiträge: 10
Themenstarter  

Nachtag 2:

da es sich um ein GMAIL Konto handelt...LESS SECURE APPS aktiviert, IMAP, POP3 aktiviert....

Strom macht klein....schwarz....und hässlich!


AntwortZitat
 Jens
(@jens78)
Active Member
Beigetreten: Vor 10 Jahren
Beiträge: 8
 

Hallo

ich habs gerade mal nachgestellt und es funktioniert mit einem Google mail Konto.

 

server: smtp.gmail.com

Port: 587

Benutzer: dein benutzer

Passwort: dein Passwort

Emailadresse: deine Google email

tls: tls

 

beim ersten senden habe ich eine Sicherheitswarnung durch Google bekommen, dass sich ein unbekanntes Gerät

mit dem Konto verbinden wollte.

Dies hab ich bestätigt dass ich es war.

Dann noch den Zugriff " Zugriff durch weniger sichere Apps" im google mail konto erlauben und schon funktioniert es.

Zumindest bei mir.

Ich habe noch die version 1.0.67 im Einsatz.

 

Gruß

Jens

Diese r Beitrag wurde geändert Vor 1 Woche von Jens

Xhome Evo 1.0.67 auf Qnap TS251+


AntwortZitat
(@snydman)
Active Member
Beigetreten: Vor 10 Jahren
Beiträge: 10
Themenstarter  

hallo jens,

danke fürs ausprobieren. mit diesem einstellungen hab ich es auch probiert. ich suche weiter nach dem fehler....

Strom macht klein....schwarz....und hässlich!


AntwortZitat
(@snydman)
Active Member
Beigetreten: Vor 10 Jahren
Beiträge: 10
Themenstarter  

DES RÄTSELS LÖSUNG:

nachdem ich dachte...zwei server und nur eine knx-schnittstelle....die könnten sich gegenseitig beeinflussen, habe ich mal schnell eine eigene kleine knx-anlage aus einer weiteren schnittstelle und nem netzteil zusammen gebaut. meinen server und auch meine schnittstelle von der fritzbox getrennt..und siehe da....der fehler ist noch da. also weiter....und das jetzt mal mit system. windows-firewall abgeschaltet...fehler noch da. acronis-active-protection abgeschaltet....fehler noch da. avast-schutzmodule abgeschaltet....und...nee nix fehler.....ER SENDET PLÖTZLICH E-MAILS. nicht zu fassen. also weiter ins detail. in den e-mail-schutzeinstellungen von avast den haken bei "prüfung ausgehende mails (smtp)" entfernt und siehe da...mit den anderen wieder eingeschalteten schutzmodulen läufts. unglaublich. seltsamer weise, wenn ich benachrichtigungen über acronis sende, spielt diese prüfung von ausgehenden mails keine rolle, eben nur bei xhome.

stundenlang den kopp zerbrochen wegen dieser dämlichen funktion....man man man....

so denn....man liest sich....

Strom macht klein....schwarz....und hässlich!


AntwortZitat
Teilen:

Durch die weitere Nutzung der Seite stimmst du der Verwendung von Cookies zu. Weitere Informationen

Die Cookie-Einstellungen auf dieser Website sind auf "Cookies zulassen" eingestellt, um das beste Surferlebnis zu ermöglichen. Wenn du diese Website ohne Änderung der Cookie-Einstellungen verwendest oder auf "Akzeptieren" klickst, erklärst du sich damit einverstanden.

Schließen