Benachrichtigungen
Alles löschen

Schnittstellen suche findet Sonos nicht


 RoSo
Active Member
Beigetreten: Vor 1 Jahr
Beiträge: 12
Themenstarter  

Hallo

Die Suche über die Schnittstellen findet das Sonos nicht.

Obschon das Sonos im Selben Netzwerk erreichbar ist.

IP Xhome Evolution Server: 192.168.68.10

KNX IP: 192.168.68.11 (wind gefunden)

IP Sonos z.B. 192.168.68.40

Hat da jemand erfahrungen, an was dies liegen kann?

Vielen Dank

roso


   
Zitat
Schlagwörter für Thema
New Member
Beigetreten: Vor 6 Jahren
Beiträge: 2
 

Moin,

In Einstellungen runter scollen bis Sonos und aktivieren.

Dann einen Neustart und ggf. den Browsercache löschen.

Dann wieder auf Einstellungen.

dort bei der Schnittstelle auf neu anlegen und die Sonos aufrufen.

Das sollte es gewesen sein.

gruß

norder


   
AntwortZitat
 RoSo
Active Member
Beigetreten: Vor 1 Jahr
Beiträge: 12
Themenstarter  

Hallo @norder

Vielen Dank für die rasche Antwort.

Also beim Gatewey Typ Sonos wählen und dann auf Schnittstellen suchen klicken?

Leider listet es aber die Sonos Produkte nicht auf. Eines heisst zum Beispiel Fernseher.

Irgendwie braucht es noch einen weiteren Trick?

Danke weitere Vorschläge.

Roso


   
AntwortZitat
Artur
Eminent Member
Beigetreten: Vor 4 Jahren
Beiträge: 35
 

Du kannst das Sonos Gerät auch einfach "händisch" hinzufügen.

Geh auf neue Schnittstelle und trage das die Daten deines Geräts ein.

Ist das ne Sonos One ?

Ich könnte mal gucken was da bei mir so drin steht.


   
AntwortZitat
 RoSo
Active Member
Beigetreten: Vor 1 Jahr
Beiträge: 12
Themenstarter  

Hoi @arturlech1988gmail-com 

Danke für deinen Typ. Leider schaffe ich es händisch auch nicht.

Ja ich habe zum Beispiel eine One, aber auch mehr.

Was genau ist die Sonos ID?

Gerne, wenn du mir einmal deine Einstellungen hier eintragen kannst, das würde mir sicher weiterhelfen.

Vielen Dank

RoSo


   
AntwortZitat
Artur
Eminent Member
Beigetreten: Vor 4 Jahren
Beiträge: 35
 

Wie in der Beschreibung des xHome Handbuchs darf der Name deiner Sonos-Box keine Sonderzeichen haben.

Hier meine Einstellungen!

Schnittstelle: Sonos

Name: Der Name deines Lautsprechers !!!Ohne Sonderzeichen!!!

Typ: Sonos

IP : ist klar!

ID : So findst du die Sonos ID deines Laufsprechers heruas:

im Browser

http://"ip deines Lautsprechers":1400/status

eingeben und dann auf

zp

klicken.

Alles, was in der Tabelle in der Zeile LocalUID steht muss in die xHome Id rein, also RINCON_....... 

 

Eigentlich ist nur die ID rauszufinden etwas kompliziert => der Rest ist eigentlich selbsterklärend


   
AntwortZitat
Artur
Eminent Member
Beigetreten: Vor 4 Jahren
Beiträge: 35
 
Veröffentlicht von: @kawaartur

Wie in der Beschreibung des xHome Handbuchs darf der Name deiner Sonos-Box keine Sonderzeichen haben.

Hier meine Einstellungen!

Schnittstelle: Sonos

Name: Der Name deines Lautsprechers !!!Ohne Sonderzeichen!!!

Typ: Sonos

IP : ist klar!

ID : So findst du die Sonos ID deines Laufsprechers heruas:

im Browser

http://"ip deines Lautsprechers":1400/status

eingeben und dann auf

zp

klicken.

Alles, was in der Tabelle in der Zeile LocalUID steht muss in die xHome Id rein, also RINCON_....... 

 

Eigentlich ist nur die ID rauszufinden etwas kompliziert => der Rest ist eigentlich selbsterklärend

Hab vergessen 🙂

 

Netzwerkkarte die IP deines xHome-Servers

 

Viel Erfolg


   
AntwortZitat
 RoSo
Active Member
Beigetreten: Vor 1 Jahr
Beiträge: 12
Themenstarter  

Hallo @kawaartur 

Vielen Dank, so finde ich die ID und kann meine Sonos auch verbinden.

Die Listen durchsuchen geht auch.

Und abspielen kann ich auch etwas und das Volumen verstellen.

Einzig stoppen geht dann nicht, es steht immer noch Play.

Kann dies noch an meiner Version liegen. Ich habe Sonos auf V2 geupdatet.

Danke

RoSo

 Sonos Fitnessraum

   
AntwortZitat
Artur
Eminent Member
Beigetreten: Vor 4 Jahren
Beiträge: 35
 

Also ich muss sagen, dass die Integration von Sonos in xHome nicht so ganz rund läuft.

Viele Funktionen gehen irgendwie nicht richtig.

Ich habe da auch so meine Probleme.

Für mich war es nur wichtig die Multiroomfunktion richtig nutzen zu können und die Lautsprecher abhängig von der Beleuchtung im Zimmer einzuschalten und entsprechend zu gruppieren. 

Das habe ich übrigens nicht komplett über xHome realisieren können.

hier kahm die PHPSonos.php von "GitHub" ins spiel.


   
AntwortZitat
 RoSo
Active Member
Beigetreten: Vor 1 Jahr
Beiträge: 12
Themenstarter  

Hallo @kawaartur 

Danke für die Info. Das beruhigt mich sehr.

Ich wollte nur über den Hauptschalter auch das Sonos gleich mit ausschalten.

Aber ich kann auch noch etwas warten irgendeinmal wird es sicher eine Anpassung geben.

Auch das mit dem Namen, wenn ich beim Fernseher den Sub und die Surround Boxen im Sonos zusammen Fasse heisst dies dann eben Fernseher (SW) was ich gar nicht beeinflussen kann. Also müsste der xHome halt schon auch die Sonderzeichen berücksichtigen können.

Aber wir warten einmal.

Vielen Dank.

RoSo


   
AntwortZitat
Teilen:
WordPress Cookie Hinweis von Real Cookie Banner